SCCM 2007 SP2: MP Install Error due to WebDAV

Standard

Today I run in a very strange issue at a customer site. During the installation of a new Primary Site the Management Point could not be installed due to a incomplete WebDAV configuration.


I was installing the Primary Site on a fresh Windows 2008 Standard Server. I installed all the prerequisites and followed the following technet article to install and configure WebDAV. I started the Configuration Manager installation and when the installation was finished I saw a blue question mark for the installation of the Management Point. I checked the MPSetup.log file in the Logs Directory of the installation and found the following error :Failed to get WebDAV settings on the machine (0x80070002).

I checked the WebDAV configuration for the second time and found out that I was forgotten to Enable WebDAV on my Default IIS Website. So I enabled WebDAV and tried to reinstall the Management Point. The installation still fails with the following log entries in the MPSetup.log:

 checking WebDAV configurations
  WebDAV settings is not setup appropriately
  [Allow property queries with infinite depth] should be true (false)
  [Allow Custom Properties] should be false (true)
  [Allow anonymous property queries] should be true (false)
  Allow [All users read access to All content] authoring rule should exist (exist)

This was very strange because the settings were correct. After some testing I found the solution to this problem. The solution was very simple. I changed the settings back to how they were in the original state. After applying those settings I did the configuration based on the technet article again. After applying again I installed the MP and the installation ended successfully. Very strange but in the end it worked for me.

One thought on “SCCM 2007 SP2: MP Install Error due to WebDAV

Leave a Reply to Nanda Cancel reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.