SCCM 2007 R2 SP2: PXE Error (PXE-T04: Access violation)

Standard

Today I had a very strange PXE error at a customer site. Recently I installed I fresh SCCM 2007 environment and we are now in the process of configuring this environment. Today we started with configuring PXE. At the Customer site they use a Linux DHCP server serving the clients. At the DHCP server we made the following exclusion:

filename "/SMSBoot/x86/wdsnbp.com"; 
next-server ;

 After we started the client we run into the following error:

PXE-T04: Access violation. 
PXE-E36: Error received from TFTP server

After getting this error we connected from a other client station to the SCCM Server via TFTP and tried to download wdsnbp.com file. At this client we got also the same error. When we replaced the “/” with “” it works from the client site. But when booting from PXE the error still comes. I searched on the Internet and was pointed in the right direction. I changed the following Register Key/Value on the SCCM Server:

Original:

[HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesWDSServerProvidersWDSTFTP] 
ReadFilter=
boot*
tmp*
SMSBoot*
SMSTemp*
SMSImages*

Changed to:

[HKEY_LOCAL_MACHINESYSTEMCurrentControlSetServicesWDSServerProvidersWDSTFTP] 
ReadFilter=
boot*
tmp*
SMSBoot*
SMSTemp*
SMSImages*
/boot/*
/tmp/*
/SMSBoot/*
/SMSTemp/*
/SMSImages/*

As final step I restarted the WDS Server service and the problem was Solved. So the problem was the way Linux is slashing file paths. I hope that this information helps people to solve this kind of problems. The article which pointed me in the right direction can be found here.